1. To purchase products here you need to validate your license here.

Error Log

Discussion in 'Support & Questions' started by jacean, Apr 21, 2016.

  1. jacean

    jacean New Member

    Error Info

    ErrorException: Illegal string offset 'id' - library/VIO/Discord/ControllerAdmin/Discord.php:27
    Generated By: wwadmin, Today at 9:47 PM

    Stack Trace
    #0 /home/wizardingworlds/public_html/forum/library/VIO/Discord/ControllerAdmin/Discord.php(27): XenForo_Application::handlePhpError(2, 'Illegal string ...', '/home/wizarding...', 27, Array)
    #1 /home/wizardingworlds/public_html/forum/library/XenForo/FrontController.php(351): VIO_Discord_ControllerAdmin_Discord->actionRoles()
    #2 /home/wizardingworlds/public_html/forum/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #3 /home/wizardingworlds/public_html/forum/admin.php(13): XenForo_FrontController->run()
    #4 {main}

    Request State
    array(3) {
    ["url"] => string(51) "http://wizardingworlds.com/forum/admin.php?discord/"
    ["_GET"] => array(1) {
    ["discord/"] => string(0) ""
    }
    ["_POST"] => array(0) {
    }
    }
     
  2. Erik

    Erik New Member

    Same error here, has this been fixed?

    Update: fixed by reading my mail (you have logged on to a different location to discord, please acknowledge mail)
     
    Last edited: May 28, 2016
  3. VanValdenburg

    VanValdenburg New Member

    Hi, i got the same problem. The mail for the authentication is too old though.
    How can i make them resend the mail? Or how can i have the plugin try to login again?
     
  4. Erik

    Erik New Member

    @VanValdenburg : just try again, it will send another mail. (or depending on where you host it, open a website from that end, unless its remotely hosted)
     
  5. VanValdenburg

    VanValdenburg New Member

    Hey man thatnks for the reply. Thing is it is indeed remotely hosted. I live in germany. But the login request is from USA.
    I tried to de-install the plugin and to change login credentials in the hope the plugin tries to login again and that i get another mail.
    But no luck it is just not sending any mail. Also tried to run the cache tool for the plugin.
     
  6. Erik

    Erik New Member

    Not the easiest way perhaps, but if you can login remote via ssh, you could just install this: https://github.com/Rivalo/discord-cli

    Thats a command line cli for discord, so basicly if that wants to login you can be pretty sure it is working, for all we know you still have an issue with xenforo somewhere.
     
  7. VanValdenburg

    VanValdenburg New Member

    Hey man thanks again for trying to solve this for me.
    However i think the plugin developer should provide me with an answer at this point.
    I do not want to use any third party plugins or setups to get this done.

    It should be easy to issue a re-install and have the plugin login again so i can get this damn email :D
    At this point am not sure what you mean with " for all we know you still have an issue with xenforo somewhere. "
    Since the only problem i have is that discord is blocking the login from the plugin. So it should not be a problem of xenforo.

    Thx man appreciate your help!
     
  8. VanValdenburg

    VanValdenburg New Member

    UPDATE: tried now with a VPN to login from USA, it did send me another authentication mail but this one was broken right away, so the link already expired.
     

Share This Page